Home > Clang Error > Clang Error No Such File Or Directory 'python.framework/versions/2.7/python'

Clang Error No Such File Or Directory 'python.framework/versions/2.7/python'

Btw a full installation of version 1.9.0 on OSX can be done like this: brew install sdl2 sdl2_image sdl2_ttf sdl2_mixer gstreamer pip install -I Cython==0.21.2 USE_OSX_FRAMEWORKS=0 pip install git+https://github.com/kivy/[email protected] krazybean commented Perhaps you had those there for a reason, I've never seen that, but removing those prefixes would probably work. How do I get the last lines of dust into the dustpan? Can Mage Hand wield a Shield? Check This Out

comment:14 Changed 3 years ago by anddam (Andrea D'Amore) Cc [email protected]… added Cc Me! how to style multi-value interpolation function plot? Not the answer you're looking for? I think this problem is due to a combination of OSX 10.10 Yosemite and Homebrew python. page

ideas on how to fix it? familys-imac:~ Paul-Arthur$ ruby -e "$(curl -fsS https://raw.github.com/gist/323731)" /usr/local/.git already exists! Note: See TracTickets for help on using tickets. build 5493)] on darwin Type "help", "copyright", "credits" or "license" for more information. >>> sgarza62$ which python /Library/Frameworks/Python.framework/Versions/2.7/bin/python sgarza62$ echo $PATH /Library/Frameworks/Python.framework/Versions/2.7/bin:/Library/Frameworks/Python.framework/Versions/2.7/bin:/usr/bin:/bin:/usr/sbin:/sbin:/usr/local/bin sgarza62$ /usr/bin/python -c 'import sys;print(sys.version)' 2.7.2 (default, Jun 16

I really wanted a rhombus, but all I got was this stupid rectangle Can morse code be called steganography? Is there oscillating charge in a hydrogen atom? adamv referenced this issue Feb 8, 2014 Closed weechat --with-python fails on OS X Mavericks #26525 deathgaze commented Feb 8, 2014 This appears to be due to a conflict with system Can Mage Hand wield a Shield?

Already have an account? I believe the issue should be reported to Homebrew. Reload to refresh your session. You can create an environment with: conda create --name my_env python=2.7 Change into it: source activate my_env and install pyamg: conda install pyamg You can still use pip to install packages

true ==> Build Flags CC: /usr/bin/llvm-gcc => /usr/llvm-gcc-4.2/bin/llvm-gcc-4.2 CXX: /usr/bin/llvm-g++ => /usr/llvm-gcc-4.2/bin/llvm-g++-4.2 LD: /usr/bin/llvm-gcc => /usr/llvm-gcc-4.2/bin/llvm-gcc-4.2 CFLAGS: -O3 -w -pipe -march=core2 -msse4.1 CXXFLAGS: -O3 -w -pipe -march=core2 -msse4.1 CPPFLAGS: -I/usr/local/Cellar/readline/6.2.1/include LDFLAGS: However, I am getting the following error. Thanks! true ==> Build Flags CC: /usr/bin/llvm-gcc => /usr/llvm-gcc-4.2/bin/llvm-gcc-4.2 CXX: /usr/bin/llvm-g++ => /usr/llvm-gcc-4.2/bin/llvm-g++-4.2 LD: /usr/bin/llvm-gcc => /usr/llvm-gcc-4.2/bin/llvm-gcc-4.2 CFLAGS: -O3 -w -pipe -march=core2 -msse4.1 CXXFLAGS: -O3 -w -pipe -march=core2 -msse4.1 CPPFLAGS: -I/usr/local/Cellar/readline/6.2.1/include LDFLAGS:

Please click the link in the confirmation email to activate your subscription. For information on other options, you may wish to consult the documentation at: http://packages.python.org/distribute/easy_install.html Please make the appropriate changes for your system and try again. ==> Exit Status: 1 http://github.com/mxcl/homebrew/blob/master/Library/Formula/python.rb#L106 ==> A 17th century colloquial term for children, in the way we use 'kids' today Too many reports because of too convenient report button more hot questions question feed lang-py about us Thank you all for your time, I appreciate it!

Join them; it only takes a minute: Sign up Error when trying to install pyamg: clang: error: no such file or directory: '“-I/…/boost_1_59_0”' up vote 8 down vote favorite I am http://buzzmeup.net/clang-error/clang-error-no-such-file-or-directory-libgcc-a.html Random integers with differing probabilities How to typeset a system of linear equations in LaTeX? I believe the issue should be reported to Homebrew. Animate finding the middle Did people in China resort to cannibalism during the reign of Mao?

What does port select python return for you? How to politely decline my salary due to feeling I don't currently deserve it? Not the answer you're looking for? this contact form If you do not have administrative access to this machine, you may wish to choose a different installation directory, preferably one that is listed in your PYTHONPATH environment variable.

For information on other options, you may wish to consult the documentation at: http://packages.python.org/distribute/easy_install.html Please make the appropriate changes for your system and try again. ==> Exit Status: 1 http://github.com/mxcl/homebrew/blob/master/Library/Formula/python.rb#L106 ==> In order to prevent conflicts when programs look for libreadline we are defaulting this GNU Readline installation to keg-only. Skip to content Ignore Learn more Please note that GitHub no longer supports old versions of Firefox.

I have this error when installing with homebrew's version of python 2.7.7_2 Installation via pip works for me on System python as well as Homebrew's python3.

For that, you have to use pythonX.Y-config --ldflags. I understand why the kivy team has not updated this since it is NOT documented by Apple. Browse other questions tagged python osx gcc installation pip or ask your own question. c++: pyamg/amg_core/amg_core_wrap.cxx clang: error: no such file or directory: '“-I/Users/mas/PycharmProjects/kaggle-ndsb/boost_1_59_0”' clang: error: no such file or directory: '“-I/Users/mas/PycharmProjects/kaggle-ndsb/boost_1_59_0”' error: Command "c++ -fno-strict-aliasing -fno-common -dynamic -arch x86_64 -arch i386 -g -Os -pipe

If you don't mind, I would very much appreciate a spoon-fed solution (explicitly stating what I have to do in the Terminal to fix this). gciding commented Jun 23, 2014 Are you using homebrew python? Scanning installed packages No setuptools distribution found running install error: can't create or remove files in install directory The following error occurred while trying to add or remove files in the navigate here I have this error when installing with homebrew's version of python 2.7.7_2 Installation via pip works for me on System python as well as Homebrew's python3. --- Reply to this email

Seen here: github.com/pypa/pip/issues/1861 –wkcamp Oct 14 '14 at 17:23 That's my bug report :) - how do I switch to python 3?